getting error "the application for the project is not installed"

Apr 17, 2009 at 9:30 AM
Hello,
Any body please help me with this problem.
I'm getting this "the application for the project is not installed" while openning the source code of the Mobile App Blocks
 in my vs team system 2008.
Is any body having such problem before? any solution for that?  


Peter
Apr 17, 2009 at 11:41 AM
I would suggest you get the source directly from svn. It is easier to update, no need to uninstall/install.
Coordinator
Apr 17, 2009 at 12:48 PM
Hi Peter,

Looks like you don't have some features of Visual Studio 2008 installed on your development box.
Please enable:
- Visual C#
- Visual C# - Smart Device Programmability
- Team Developer and Tester Tools - Testing Tools

And install:

Windows Mobile 6 SDKs (Professional and Standard Edition) Refresh
http://www.microsoft.com/downloads/details.aspx?FamilyID=06111A3A-A651-4745-88EF-3D48091A390B&displaylang=en

Optionally, for using the Data Access Block, Disconnected Agent and Subscription Block, you should install:
SQL Server Compact Edition 3.5 SP1 for windows mobile
http://www.microsoft.com/downloads/details.aspx?FamilyID=FCE9ABBF-F807-45D6-A457-AB5615001C8F&displaylang=en

You also need Windows Mobile Device Center or Active Sync installed depending on your operating system (WMDC for Vista and AS for earlier versions).

HTH,

-Joe
Coordinator
Apr 17, 2009 at 12:52 PM
Edited Apr 17, 2009 at 1:52 PM
Btw, I'm adding this information as part of the Wiki so we can avoid this pre-requisites issue in the future.
http://mobile.codeplex.com/Wiki/View.aspx?title=Mobile%20Application%20Blocks%20Requirements
Let us know if this solves your problem
Thanks for your feedback!
Apr 23, 2009 at 2:26 AM
Thank you for your quick respond.
My problem finally solved by reinstalling my vs 2008 and every thing seams fine so far.
Thank you again for your help.

Peter
May 7, 2009 at 6:28 PM
Same problem here. Any plans to create .csproj/.sln using Visual Studio 2008 Professional Edition v 9.0.21022.8 RTM?

Thanks
May 7, 2009 at 6:39 PM
FYI,

I am using the following: 

+ Visual Studio 2008 Professional Edition V 9.0.30729.1 SP
+ SQL Server Compact Edition for 3.5 SP1 (link above)
+ Windows Mobile 6 SDKs (link above)

And have experienced no issues outside of the unrelated  issue of the designer being extremely fragile when you subclass controls however I see this has been a problem since VS2005 - it put me a few weeks behind schedule but I found a workaround to it, blog follows:

http://www.global-webnet.net/blogengine/post/2009/03/20/Mobile-Framework-for-Mobile-50-Resolving-unmapped-Interface-returns-null.aspx



Coordinator
May 7, 2009 at 7:00 PM
Hi lkshikoh,

.csproj and .sln files don't target specific Visual Studio builds. Looks like your environment is missing some visual studio features or a WM SDK.
Can you please confirm that youhave installed all the pre-requisites listed on the requirement list?

Regards.
May 8, 2009 at 12:26 PM

Fixed it. For some reason, I had both Windows Mobile 6 Standard SDK and Windows Mobile 6 Professional SDK installed. After uninstalling both of these, then reinstalling WM 6 Pro SDK, I can now open the projects, compile, and link.

Any How-To's on the Disconnected Agent and Configuration blocks?

Appreciate the quick responses!

Lee